OK
AJAX error!

Les forumsDictionnaireDictionnaire 4.6

Dictionnaire 4.6

Cette version est dans la continuité des précédentes, aucune révolution en cours.

Nouveautés :
— le bug de Hunspell empêchant la reconnaissance des mots avec majuscule, apostrophe et majuscule successives, comme « L’Institut » a été contourné, et ces mots ne seront désormais plus soulignés en rouge ;
— cette version du dictionnaire et les suivantes seront dorénavant distribuées uniquement sous la licence MPL v2.0 (au lieu des trois licences MPL 1.1, LGPL, GPL), suivant en cela Mozilla et TDF qui distribuent leurs logiciels sous cette licence (le changement est encore en cours pour LibreOffice) ; ça ne change pas grand-chose au final, mais ça simplifie grandement la lecture des droits accordés ;
— environ 600 nouvelles entrées.

Merci à Tbj pour son assiduité, à dominiko pour m’avoir sorti de ma torpeur pour le bug de Hunspell ;) et à tous les autres pour leur participation.
le 03 septembre 2012 à 10:08
Merci pour cette nouvelle version; comptes-tu la fournir sous la forme classique "oxt" ?

Sous ma version de Linux (Mageia 2) et libreoffice 3.5.5.3, je suis parvenu à ajouter
comme extension le fichier hunspell-fr-moderne-v4.6.zip, cela a été accepté,
mais ce n'est pas tout à fait ce qu'il faut...
Au bout de quelques tests, je vois que le correcteur ne trouve pas les nouveaux mots
qui sont dans fr-moderne.dic (comme aérotransportée) et "L'Institut" est toujours problématique...

Je n'ai plus qu'a essayé de l'enlever et il se défend bien, le zip ;-)


Hors sujet : j'ai installé très facilement Grammalecte 0.2
le 03 septembre 2012 à 15:41

Tbj :
Merci pour cette nouvelle version; comptes-tu la fournir sous la forme classique "oxt" ?


?
C’est fourni sur la même page que Grammalecte. ;)
le 03 septembre 2012 à 15:44
Oui....malin je suis... je suis passé par la page "Télécharger" et j'avais aussi cherché
sur les sites d'extensions Libreoffice et OpenOffice. En cherchant sur Internet,
c'est fou ce qui reste comme versions anciennes...

Par la même occasion je suis passé en Libreoffice 3.6.1.2...
... maintenant L’Institut aérotransporté (même si cela ne veut rien dire)
ne donne plus de faute.

Au fait, dans LibO 3.6, il y a un module "Dictionnaires d'orthographe, des synonymes, de grammaire et ...",
cela ne rentre pas en conflit avec Grammalecte ?
le 03 septembre 2012 à 16:24
Les sites d’extensions me cassent les pieds. Ça a encore un sens pour Mozilla, puisque la mise à jour est mise à disposition pour Firefox et Thunderbird automatiquement, mais je songe à me passer les sites de LibO et OO…

cela ne rentre pas en conflit avec Grammalecte ?


Je présume que tu parles du correcteur anglais. Non, pas de conflit avec Grammalecte. Les correcteurs grammaticaux ne se font pas la guerre tant qu’ils ne reçoivent pas pour consigne de gérer la même langue.

Si tu tapes un paragraphe et que tu l’assignes à la langue anglaise, Grammalecte ne s’en occupera pas. De même, Lightproof (en) se s’occupe pas des paragraphes assignés au français.
le 03 septembre 2012 à 16:35

Les sites d’extensions me cassent les pieds. Ça a encore un sens pour Mozilla, puisque la mise à jour est mise à disposition pour Firefox et Thunderbird automatiquement, mais je songe à me passer les sites de LibO et OO…



Je vois que le module "Dictionnaires français 4.6" est disponible pour Firefox,
mais il est indiqué Non disponible pour Firefox 10.0.7

C'est "Eux" qui s'en occupent ? Y-a-t'il de l'espoir ?
(pour rappel, il est aussi marqué que la méthode de recopier les *dic et *.aff est déconseillée
dans la page Téléchargement de Dicollecte)

Je n'oserais même plus te poser la question pour Thunderbird, qui semble ne pas proposer la 4.6

À part cela, Grammalecte 0.2 et la version 4.6 ont déjà bien "chauffé" chez moi...

Btw - tentation diabolique - et si tu rajoutais Grammalecte et Dicollecte dans nos dictionnaires (dép., TM ?) ;
mare de les voir soulignés en rouges ;-)
le 05 septembre 2012 à 14:53

Tbj :Je vois que le module "Dictionnaires français 4.6" est disponible pour Firefox,
mais il est indiqué Non disponible pour Firefox 10.0.7

C'est "Eux" qui s'en occupent ? Y-a-t'il de l'espoir ?


Non, c’est moi qui décide de la compatibilité, et j’ai restreint celle-ci parce que les anciennes versions ne comprennent pas la BCP 47 (www.dicollecte.org…)

(pour rappel, il est aussi marqué que la méthode de recopier les *dic et *.aff est déconseillée
dans la page Téléchargement de Dicollecte)


Je ne sais même plus pourquoi c’est déconseillé. Sans doute une raison futile. :)

À part cela, Grammalecte 0.2 et la version 4.6 ont déjà bien "chauffé" chez moi...


Ah ? N’oublie pas de rapporter les faux positifs.

Btw - tentation diabolique - et si tu rajoutais Grammalecte et Dicollecte dans nos dictionnaires (dép., TM ?) ;
mare de les voir soulignés en rouges ;-)


Pourquoi ? Tu écris souvent ces mots-là, toi ? :D
le 05 septembre 2012 à 15:10


le bug de Hunspell empêchant la reconnaissance des mots avec majuscule, apostrophe et majuscule successives, comme « L’Institut » a été contourné, et ces mots ne seront désormais plus soulignés en rouge ;



L'Institut va toujours bien. L'Arabie aussi. Mais dans le cas de mots que l'on ajoute à un dictionnaire personnel ?
Exemple :
Vincent d'Indy, célèbre compositeur...
D'Indy, célèbre compositeur,...
Je ne sais pas si tu peux augmenter ton "contournement", pour couvrir ces cas ?

Edit : c'est contournable en entrant d'Indy ET D'Indy dans son dictionnaire personnel; par après il n'est plus souligné.
le 08 octobre 2012 à 15:18
Les dictionnaires personnels n’utilisent pas Hunspell, c’est juste une liste de mots. Je crois qu’il était question, if fut un temps, d’en faire des dicos comme les autres, puis il y a eu le fork LibreOffice. C’est passé à la trappe.
le 08 octobre 2012 à 17:16
Hors sujet peut-être, songer à commencer un nouveau fil pour "Dictionnaire 4.7" ?
le 09 octobre 2012 à 12:46

Notification par e-mail    0